Title

Message

Confirm

<< DiscussionsReply

Triggers not activating on all Windows

Andy Bell1
4 discussion posts
Hi

I'm trying to get triggers to occur on Codegear RAD Studio 2007 - a software development app.

I've tried everything, even setting Process File Name to *.* but it does not detect it.

Additionally, if I launch a program under development from this IDE it is not detected. But, if I run the program under development from Windows Explorer, it is detected...

Codegear RAD Studio 2007 appears in Windows Task Manager...

Any ideas?

Andy
• Attachment [protected]: TrayStatusDebugInfo.zip [17,262 bytes]
Oct 3, 2020  • #1
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hey Andy,

When you go open your trigger settings and select the application, have you tried dragging the blue cross hair at the bottom over top of the window?

Thanks!
Oct 6, 2020  • #2
Andy Bell1
4 discussion posts
Yes, tried that. It correctly picked up the name of the window but the trigger still does not fire...

Andy
Oct 6, 2020  • #3
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hey Andy,

Could you try setting the match condition to "window text" instead of "process filename"? Try setting it to something like "codegear", "rad", or something along those lines.

Let me know how that works for you!
Oct 7, 2020  • #4
Andy Bell1
4 discussion posts
Tried that too - no joy, I'm afraid...
Oct 7, 2020  • #5
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hey Andy,

Can you exit out of tray status, either through the tray or through task manager, and run it as administrator and see if that helps?

Thanks!
Oct 8, 2020  • #6
Andy Bell1
4 discussion posts
Hi

Yes, running as Administrator makes it detect this program properly...

Andy
Oct 10, 2020  • #7
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hey Andy,

So it sounds like Codegear is running with elevated privileges, so Traystatus also needs to be run as administrator. If you pin tray status to a Display Fusion taskbar, you can right click the pinned icon and select "edit this pinned item". You can then check off "Launch Application as Administrator" to automatically load it with elevated privileges when run.

Hope this helps!
Oct 13, 2020  • #8
Was this helpful?    
<< DiscussionsReply